$re = '/^[a-z0-9]+[\._]?[a-z0-9]|[@]\w+[.]\w{2,3}$/m';
$str = '
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);