package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]+[\._]?[a-z0-9]|[@]\w+[.]\w{2,3}$`)
var str = `
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}