package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SIC:\s(\d{2,})\s`)
var str = `IRS No.: 208677788 | State of Incorp.: CO | Fiscal Year End: 0630Type: 10-K | Act: 34 | File No.: 000-53875 | Film No.: 161939487SIC: 5960 Retail-Nonstore RetailersAssistant Director 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}