using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SIC:\s(\d{2,})\s";
string input = @"IRS No.: 208677788 | State of Incorp.: CO | Fiscal Year End: 0630Type: 10-K | Act: 34 | File No.: 000-53875 | Film No.: 161939487SIC: 5960 Retail-Nonstore RetailersAssistant Director 2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}