#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)username\s([a-zA-Z0-9]*)(?>\sprivilege\s([0-9]{1,2}))?.*"
Local $sString = "username ytnflvby secret <hash>" & @CRLF & _
"username eec privilege 15 secret <hash>" & @CRLF & _
"username protuser privilege 3 password 7 <hash>" & @CRLF & _
"username wheel privilege 0 secret <hash>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")