# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?\:\/\/|[a-zA-Z0-9]?)([a-zA-Z0-9\-]+\.host\.[a-zA-Z0-9]+$|host\.[a-zA-Z0-9]+$)"
test_str = ("#### should MATCH all of these:\n"
"http://www.host.com\n"
"https://www.host.com\n"
"https://www.host.com\n"
"http://host.com\n"
"http://www.host.tv\n"
"https://www.host.live\n"
"host.com\n"
"www.host.com\n"
"http://sub-services.host.com\n"
"sub-services.host.com\n"
"g.host.com\n"
"gg.host.com\n"
"gggg.host.com\n"
"something-services.host.com\n\n"
"#### should NOT MATCH all of these:\n"
"http://www.something.com\n"
"http://www.host-something.com\n"
"http://www.host.something-com\n\n"
"http://www.hosts.com\n"
"https://www.host\n"
"https://www.host.live.com\n"
"http://.host.com\n"
"http://www.host.tv.com\n"
"something.com\n"
".host.com\n"
"www.com\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.