#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?\:\/\/|[a-zA-Z0-9]?)([a-zA-Z0-9\-]+\.host\.[a-zA-Z0-9]+$|host\.[a-zA-Z0-9]+$)"
Local $sString = "#### should MATCH all of these:" & @CRLF & _
"http://www.host.com" & @CRLF & _
"https://www.host.com" & @CRLF & _
"https://www.host.com" & @CRLF & _
"http://host.com" & @CRLF & _
"http://www.host.tv" & @CRLF & _
"https://www.host.live" & @CRLF & _
"host.com" & @CRLF & _
"www.host.com" & @CRLF & _
"http://sub-services.host.com" & @CRLF & _
"sub-services.host.com" & @CRLF & _
"g.host.com" & @CRLF & _
"gg.host.com" & @CRLF & _
"gggg.host.com" & @CRLF & _
"something-services.host.com" & @CRLF & _
"" & @CRLF & _
"#### should NOT MATCH all of these:" & @CRLF & _
"http://www.something.com" & @CRLF & _
"http://www.host-something.com" & @CRLF & _
"http://www.host.something-com" & @CRLF & _
"" & @CRLF & _
"http://www.hosts.com" & @CRLF & _
"https://www.host" & @CRLF & _
"https://www.host.live.com" & @CRLF & _
"http://.host.com" & @CRLF & _
"http://www.host.tv.com" & @CRLF & _
"something.com" & @CRLF & _
".host.com" & @CRLF & _
"www.com" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")