use strict;
my $str = 'A 10.95.151.82 5, A 10.95.151.81 5, AAAA fd88:3be1:fee4:8c5d::2c 5, AAAA fd88:3be1:fee4:8c5c::2a 5';
my $regex = qr/(?P<ip_class>A{1,4}) (?P<ip>[a-f,A-Z,0-9,:,\.]+) (?P<ttl>\d+)(?P<comma_space>, )?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}