#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<ip_class>A{1,4}) (?P<ip>[a-f,A-Z,0-9,:,\.]+) (?P<ttl>\d+)(?P<comma_space>, )?"
Local $sString = "A 10.95.151.82 5, A 10.95.151.81 5, AAAA fd88:3be1:fee4:8c5d::2c 5, AAAA fd88:3be1:fee4:8c5c::2a 5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")