# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^[^\-]*)\W([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+([^\s]*)\s+(.*$)"
test_str = "Jul 28 08:27:40 Mon-iWEB-R03-APS-01 authproc1_auth01 {\"actn\":76,\"pckId\":\"7a25f9c4bb39cacf\",\"sId\":\"354669705072900392110145246\",\"utId\":106854,\"did\":\"60b265bd68322e8c\",\"dvcc\":3,\"vsn\":\"139\"}"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.