re = /(?i)(beatiful| ).*(people[a-zA-Z0-9]{2,3})/
str = 'I am charming and friendly people00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end