$re = '/(?i)(beatiful| ).*(people[a-zA-Z0-9]{2,3})/';
$str = 'I am charming and friendly people00';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);