import Foundation
let pattern = #"^[0-9\)\(\s+-]+(\s?(?:x|extension|ext\.)\s?[0-9-]+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
555-555-5555
555-555-5555 x55555
555-555-5555x55555
555-555-5555 extension 55555
555-555-5555 ext. 55555
(555) 555-5555
5555555555
555-5555
5555555
1-800-CONTACTS
1-800-555-5555
Hello world
(555-555-5555
0-999-0349300
+43 984-899-46515
+43 some bogus
939403 03904 aosdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)