// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[0-9\)\(\s+-]+(\s?(?:x|extension|ext\.)\s?[0-9-]+)?$").unwrap();
let string = "555-555-5555
555-555-5555 x55555
555-555-5555x55555
555-555-5555 extension 55555
555-555-5555 ext. 55555
(555) 555-5555
5555555555
555-5555
5555555
1-800-CONTACTS
1-800-555-5555
Hello world
(555-555-5555
0-999-0349300
+43 984-899-46515
+43 some bogus
939403 03904 aosdf
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}