$re = '/^FWD:\[(?<pid>[0-9]{4})\] (?<prog>.+\.exe): (?<msg>.*)$/m';
$str = 'FWD:[1234] something else.exe: a bunch of text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);