const regex = /^FWD:\[(?<pid>[0-9]{4})\] (?<prog>.+\.exe): (?<msg>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^FWD:\\[(?<pid>[0-9]{4})\\] (?<prog>.+\\.exe): (?<msg>.*)$', 'gm')
const str = `FWD:[1234] something else.exe: a bunch of text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}