re = /(?<=\sRechnungsbetrag\s\(inklusive Umsatzsteuer\))\s(?P<asd>\d{1,}).?(?P<fgh>\d{1,})?/m
str = 'Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR
Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR
Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR
Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end