use strict;
my $str = 'Rechnungsbetrag (ohne Umsatzsteuer) 299,05 EUR
Umsatzsteuer (C1) 19% von 299,05 EUR 56,82 EUR
Rechnungsbetrag (inklusive Umsatzsteuer) 355,87 EUR
Wir buchen den Betrag frühestens am 05.07.2017 von Ihrem Konto IBAN DE17240400000438401200, BIC COBADEFFXXX ab.';
my $regex = qr/(?<=\sRechnungsbetrag\s\(inklusive Umsatzsteuer\))\s(?P<asd>\d{1,}).?(?P<fgh>\d{1,})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}