import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(/?[BIT)(html)(body)(title)(head)]+)>";
final String string = "Native object recogition <B>is much better</B> then other types. Or <I>is in italic</I> and not in <B>bold</B> types <b>face</b>. \n\n\n"
+ "<!DOCTYPE HTML>\n"
+ "<html>\n"
+ "<head>\n"
+ "<title>Title of the document</title>\n"
+ "</head>\n\n"
+ "<body>\n"
+ "The content of the document......\n"
+ "</body>\n\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}