#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<(/?[BIT)(html)(body)(title)(head)]+)>"
Local $sString = "Native object recogition <B>is much better</B> then other types. Or <I>is in italic</I> and not in <B>bold</B> types <b>face</b>. " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!DOCTYPE HTML>" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
"<title>Title of the document</title>" & @CRLF & _
"</head>" & @CRLF & _
"" & @CRLF & _
"<body>" & @CRLF & _
"The content of the document......" & @CRLF & _
"</body>" & @CRLF & _
"" & @CRLF & _
"</html>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")