re = /^1?$|^(11+?)\1+$/m
str = '
1
11
111
1111
11111
111111
1111111
11111111
111111111
1111111111
11111111111
111111111111
1111111111111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end