import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^1?$|^(11+?)\\1+$";
final String string = "\n"
+ "1\n"
+ "11\n"
+ "111\n"
+ "1111\n"
+ "11111\n"
+ "111111\n"
+ "1111111\n"
+ "11111111\n"
+ "111111111\n"
+ "1111111111\n"
+ "11111111111\n"
+ "111111111111\n"
+ "1111111111111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}