const regex = /^(?=.*?[1-9])[0-9\\,\\-]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*?[1-9])[0-9\\\\,\\\\-]+$', '')
const str = `90,91,90-200,90,900-9000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);