re = /(?<email>(?<username>[\w\W]+)@(?<domain>[\w\W]+\.[\w\W]+|localhost))/i
str = 'helloworld@arealaddress.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end