package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?<email>(?<username>[\w\W]+)@(?<domain>[\w\W]+\.[\w\W]+|localhost))`)
var str = `helloworld@arealaddress.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}