$re = '/^(\d+\')?(?:(?<=\')\s*-\s*)?(\d+(?:\s*\d+\/\d+|\.\d+)?")$/';
$str = '111\' - 12.01"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);