using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+')?(?:(?<=')\s*-\s*)?(\d+(?:\s*\d+\/\d+|\.\d+)?"")$";
string input = @"111' - 12.01""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}