re = /(((?:\<|\[)a href=\'|\")?((?:http:\/\/)?((?:www\.)?(?:[\w\d-_]*?\.)+(?:\w{2,4}))(?:\/?)(?:[\w\d-_]+))((?:(?:\'|\")(?:\>|\]))(?:[\w\d-_]+)(?:(?:\<|\[)\/a(?:\>|\])))?)/i
str = '[a href=\'http://vk.com/id9025145\']ntcn[/a]
<a href=\'http://vk.com/id9025145\'>ntcn</a>
http://vk.com/id9025145'
# Print the match result
str.match(re) do |match|
puts match.to_s
end