using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((?:\<|\[)a href=\'|\"")?((?:http:\/\/)?((?:www\.)?(?:[\w\d-_]*?\.)+(?:\w{2,4}))(?:\/?)(?:[\w\d-_]+))((?:(?:\'|\"")(?:\>|\]))(?:[\w\d-_]+)(?:(?:\<|\[)\/a(?:\>|\])))?)";
string input = @"[a href='http://vk.com/id9025145']ntcn[/a]
<a href='http://vk.com/id9025145'>ntcn</a>
http://vk.com/id9025145";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}