$re = '/(?!\d\.\d)(\w\.+)(?! )(\w?)/m';
$str = 'This is a sample text. Just 1.2 to test.To add a space after the dot...Okay.
I watched football.10 people played in 2 teams, my friend was player number 7. 20 minutes later the game ended with the score 2:1.Then I went home.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);