const regex = /(?!\d\.\d)(\w\.+)(?! )(\w?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\d\\.\\d)(\\w\\.+)(?! )(\\w?)', 'gm')
const str = `This is a sample text. Just 1.2 to test.To add a space after the dot...Okay.
I watched football.10 people played in 2 teams, my friend was player number 7. 20 minutes later the game ended with the score 2:1.Then I went home.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}