# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:[A-Z\s]+\n)"
test_str = ("MATCH THE FOLLOWING\n\n"
"http://foo.com/blah_blah\n"
"http://foo.com/blah_blah/\n"
"http://foo.com/blah_blah_(wikipedia)\n"
"http://foo.com/blah_blah_(wikipedia)_(again)\n"
"http://www.example.com/wpstyle/?p=364\n"
"https://www.example.com/foo/?bar=baz&inga=42&quux\n"
"http://✪df.ws/123\n"
"http://userid:password@example.com:8080\n"
"http://userid:password@example.com:8080/\n"
"http://userid@example.com\n"
"http://userid@example.com/\n"
"http://userid@example.com:8080\n"
"http://userid@example.com:8080/\n"
"http://userid:password@example.com\n"
"http://userid:password@example.com/\n"
"http://142.42.1.1/\n"
"http://142.42.1.1:8080/\n"
"http://➡.ws/䨹\n"
"http://⌘.ws\n"
"http://⌘.ws/\n"
"http://foo.com/blah_(wikipedia)#cite-1\n"
"http://foo.com/blah_(wikipedia)_blah#cite-1\n"
"http://foo.com/unicode_(✪)_in_parens\n"
"http://foo.com/(something)?after=parens\n"
"http://☺.damowmow.com/\n"
"http://code.google.com/events/#&product=browser\n"
"http://j.mp\n"
"ftp://foo.bar/baz\n"
"http://foo.bar/?q=Test%20URL-encoded%20stuff\n"
"http://مثال.إختبار\n"
"http://例å.测试\n"
"http://उदाहरण.परीकà¥à¤·à¤¾\n"
"http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com\n"
"http://1337.net\n"
"http://a.b-c.de\n"
"http://223.255.255.254\n\n"
"DONT NOT MATCH THE FOLLOWING\n\n"
"http://\n"
"http://.\n"
"http://..\n"
"http://../\n"
"http://?\n"
"http://??\n"
"http://??/\n"
"http://#\n"
"http://##\n"
"http://##/\n"
"http://foo.bar?q=Spaces should be encoded\n"
"//\n"
"//a\n"
"///a\n"
"///\n"
"http:///a\n"
"foo.com\n"
"rdar://1234\n"
"h://test\n"
"http:// shouldfail.com\n"
":// should fail\n"
"http://foo.bar/foo(bar)baz quux\n"
"ftps://foo.bar/\n"
"http://-error-.invalid/\n"
"http://a.b--c.de/\n"
"http://-a.b.co\n"
"http://a.b-.co\n"
"http://0.0.0.0\n"
"http://10.1.1.0\n"
"http://10.1.1.255\n"
"http://224.1.1.1\n"
"http://1.1.1.1.1\n"
"http://123.123.123\n"
"http://3628126748\n"
"http://.www.foo.bar/\n"
"http://www.foo.bar./\n"
"http://.www.foo.bar./\n"
"http://10.1.1.1\n"
"http://10.1.1.254 ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.