#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[A-Z\s]+\n)"
Local $sString = "MATCH THE FOLLOWING" & @CRLF & _
"" & @CRLF & _
"http://foo.com/blah_blah" & @CRLF & _
"http://foo.com/blah_blah/" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)" & @CRLF & _
"http://foo.com/blah_blah_(wikipedia)_(again)" & @CRLF & _
"http://www.example.com/wpstyle/?p=364" & @CRLF & _
"https://www.example.com/foo/?bar=baz&inga=42&quux" & @CRLF & _
"http://✪df.ws/123" & @CRLF & _
"http://userid:password@example.com:8080" & @CRLF & _
"http://userid:password@example.com:8080/" & @CRLF & _
"http://userid@example.com" & @CRLF & _
"http://userid@example.com/" & @CRLF & _
"http://userid@example.com:8080" & @CRLF & _
"http://userid@example.com:8080/" & @CRLF & _
"http://userid:password@example.com" & @CRLF & _
"http://userid:password@example.com/" & @CRLF & _
"http://142.42.1.1/" & @CRLF & _
"http://142.42.1.1:8080/" & @CRLF & _
"http://➡.ws/䨹" & @CRLF & _
"http://⌘.ws" & @CRLF & _
"http://⌘.ws/" & @CRLF & _
"http://foo.com/blah_(wikipedia)#cite-1" & @CRLF & _
"http://foo.com/blah_(wikipedia)_blah#cite-1" & @CRLF & _
"http://foo.com/unicode_(✪)_in_parens" & @CRLF & _
"http://foo.com/(something)?after=parens" & @CRLF & _
"http://☺.damowmow.com/" & @CRLF & _
"http://code.google.com/events/#&product=browser" & @CRLF & _
"http://j.mp" & @CRLF & _
"ftp://foo.bar/baz" & @CRLF & _
"http://foo.bar/?q=Test%20URL-encoded%20stuff" & @CRLF & _
"http://مثال.إختبار" & @CRLF & _
"http://例å.测试" & @CRLF & _
"http://उदाहरण.परीकà¥à¤·à¤¾" & @CRLF & _
"http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com" & @CRLF & _
"http://1337.net" & @CRLF & _
"http://a.b-c.de" & @CRLF & _
"http://223.255.255.254" & @CRLF & _
"" & @CRLF & _
"DONT NOT MATCH THE FOLLOWING" & @CRLF & _
"" & @CRLF & _
"http://" & @CRLF & _
"http://." & @CRLF & _
"http://.." & @CRLF & _
"http://../" & @CRLF & _
"http://?" & @CRLF & _
"http://??" & @CRLF & _
"http://??/" & @CRLF & _
"http://#" & @CRLF & _
"http://##" & @CRLF & _
"http://##/" & @CRLF & _
"http://foo.bar?q=Spaces should be encoded" & @CRLF & _
"//" & @CRLF & _
"//a" & @CRLF & _
"///a" & @CRLF & _
"///" & @CRLF & _
"http:///a" & @CRLF & _
"foo.com" & @CRLF & _
"rdar://1234" & @CRLF & _
"h://test" & @CRLF & _
"http:// shouldfail.com" & @CRLF & _
":// should fail" & @CRLF & _
"http://foo.bar/foo(bar)baz quux" & @CRLF & _
"ftps://foo.bar/" & @CRLF & _
"http://-error-.invalid/" & @CRLF & _
"http://a.b--c.de/" & @CRLF & _
"http://-a.b.co" & @CRLF & _
"http://a.b-.co" & @CRLF & _
"http://0.0.0.0" & @CRLF & _
"http://10.1.1.0" & @CRLF & _
"http://10.1.1.255" & @CRLF & _
"http://224.1.1.1" & @CRLF & _
"http://1.1.1.1.1" & @CRLF & _
"http://123.123.123" & @CRLF & _
"http://3628126748" & @CRLF & _
"http://.www.foo.bar/" & @CRLF & _
"http://www.foo.bar./" & @CRLF & _
"http://.www.foo.bar./" & @CRLF & _
"http://10.1.1.1" & @CRLF & _
"http://10.1.1.254 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")