re = /location_1_coordinates\=\"\[(?<longitude>[-\.\d]*)\, (?<latitude>[-\.\d]*)/
str = '01/28/2017 23:50:00 -0500, search_name="Update Baltimore Incidents", search_now=1486130400.000, info_max_time=1486130400.000, info_search_time=1486130401.183, crimecode=3AF, crimedate="2017-01-28T00:00:00.000", crimetime="23:50:00", ctime="2017-01-28T23:50:00", description="ROBBERY - STREET", district=WESTERN, inside_outside=O, location="2700 PENNSYLVANIA AVE", location_1="{u\'coordinates\': [-76.64548, 39.31253], u\'type\': u\'Point\'}", location_1_coordinates="[-76.64548, 39.31253]", location_1_type=Point, neighborhood="Penn North", post=733, premise=STREET, total_incidents=1, weapon=FIREARM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end