use strict;
my $str = '01/28/2017 23:50:00 -0500, search_name="Update Baltimore Incidents", search_now=1486130400.000, info_max_time=1486130400.000, info_search_time=1486130401.183, crimecode=3AF, crimedate="2017-01-28T00:00:00.000", crimetime="23:50:00", ctime="2017-01-28T23:50:00", description="ROBBERY - STREET", district=WESTERN, inside_outside=O, location="2700 PENNSYLVANIA AVE", location_1="{u\'coordinates\': [-76.64548, 39.31253], u\'type\': u\'Point\'}", location_1_coordinates="[-76.64548, 39.31253]", location_1_type=Point, neighborhood="Penn North", post=733, premise=STREET, total_incidents=1, weapon=FIREARM';
my $regex = qr/location_1_coordinates\=\"\[(?<longitude>[-\.\d]*)\, (?<latitude>[-\.\d]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}