$re = '/(?<=partn_key_yr_hr=)(\d{10}|\d{8})(?=\/)/m';
$str = 'csdasd/asdfadsf/partn_key_yr_hr=20220102/2343243dsfasdf=adsfadsf/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);