const regex = new RegExp('(?<=partn_key_yr_hr=)(\\d{10}|\\d{8})(?=\\/)', 'gm')
const str = `csdasd/asdfadsf/partn_key_yr_hr=20220102/2343243dsfasdf=adsfadsf/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}