import Foundation
let pattern = #"^(\+)(?(1))\d{1,3}?[- ]?\d{10}$|^([^0])(?(1))\d{9}?$|^([0])(?(1))\d{10}?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+91-4040404040"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}