const regex = /^(\+)(?(1))\d{1,3}?[- ]?\d{10}$|^([^0])(?(1))\d{9}?$|^([0])(?(1))\d{10}?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+)(?(1))\\d{1,3}?[- ]?\\d{10}$|^([^0])(?(1))\\d{9}?$|^([0])(?(1))\\d{10}?$', '')
const str = `+91-4040404040`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}