use strict;
my $str = 'CA_LSE2B9';
my $regex = qr/CA_[A-Z][0-9][A-Z]\h?[0-9][A-Z][0-9]|US_[0-9]{5}|GB_(?:(?:[A-Z][0-9]|[A-Z][0-9]{2}|[A-Z]{2}[0-9]|[A-Z]{2}[0-9]{2}|[A-Z][0-9][A-Z]|[A-Z]{2}[0-9][A-Z])\h?[0-9][A-Z]{2}|GIR\h?0AA)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}