package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`CA_[A-Z][0-9][A-Z]\h?[0-9][A-Z][0-9]|US_[0-9]{5}|GB_(?:(?:[A-Z][0-9]|[A-Z][0-9]{2}|[A-Z]{2}[0-9]|[A-Z]{2}[0-9]{2}|[A-Z][0-9][A-Z]|[A-Z]{2}[0-9][A-Z])\h?[0-9][A-Z]{2}|GIR\h?0AA)`)
var str = `CA_LSE2B9`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}