$re = '/\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\s/i';
$str = '
BTC addr ess to send to: 181q2Mb7EzHJr2bF1RdsWpDJn8THyPfNAX
[case-sensitive copy and paste it]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);