package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s[13][a-km-zA-HJ-NP-Z1-9]{25,34}\s`)
var str = `
BTC address to send to: 181q2Mb7EzHJr2bF1RdsWpDJn8THyPfNAX
[case-sensitive copy and paste it]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}