use strict;
my $str = 'persaingan dua pembalap mercedes kembali terjadi pada balapan gp formula 1 monaco. nico rosberg akhirnya sukses memutus rangkaian kemenangan rekan satu timnya, lewis hamilton yang finis di posisi kedua pada balapan yang digelar seksual seks sensual ';
my $regex = qr/[^0-9a-z]?(bikini|b[i|e]rah[i|e]|b[o|u]g[i|e]l|[men|di]?cabul[i]?|cialis|[dic|menc|menyu]?umbu[i]?|dildo|[ng]?ent[o|i]t|ereksi|eroti[k|c]|gay|jemb[u|e]t|judi|[c|k]ondom|kontol|kunam|lesb[o|ian]|libido|lucah|memek|[dip|pem]?erkosa|miras|penis|pepek|porno|puting|rog[o|e]l|seks|se[k|n]sual|sex]|telanjang|telugu|tetek|titit|toge[l]?|tocil|vagina|viagra|orgasm[e]?|kemaluan|k[e]?lamin|[ngen|jan]cuk)[^0-9a-z]/imsp;
my $subst = '###BAD###';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";