import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9a-z]?(bikini|b[i|e]rah[i|e]|b[o|u]g[i|e]l|[men|di]?cabul[i]?|cialis|[dic|menc|menyu]?umbu[i]?|dildo|[ng]?ent[o|i]t|ereksi|eroti[k|c]|gay|jemb[u|e]t|judi|[c|k]ondom|kontol|kunam|lesb[o|ian]|libido|lucah|memek|[dip|pem]?erkosa|miras|penis|pepek|porno|puting|rog[o|e]l|seks|se[k|n]sual|sex]|telanjang|telugu|tetek|titit|toge[l]?|tocil|vagina|viagra|orgasm[e]?|kemaluan|k[e]?lamin|[ngen|jan]cuk)[^0-9a-z]";
final String string = "persaingan dua pembalap mercedes kembali terjadi pada balapan gp formula 1 monaco. nico rosberg akhirnya sukses memutus rangkaian kemenangan rekan satu timnya, lewis hamilton yang finis di posisi kedua pada balapan yang digelar seksual seks sensual ";
final String subst = "###BAD###";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}