$re = '/("\D*")/';
$str = 'kdjfkhdf d "VALUE" #0937843';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);