const regex = /^.{1,100}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{1,100}$', '')
const str = `12333333dhiahodihahdfl iashflhasdflhasldhfldsak hflkdsahflkhsalkfhlkashfdsafasfasfsafasdfsfdsfdsafsaff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}