using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.{1,100}$";
string input = @"12333333dhiahodihahdfl iashflhasdflhasldhfldsak hflkdsahflkhsalkfhlkashfdsafasfasfsafasdfsfdsfdsafsaff";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}