re = /(?!.*(?:this|and|that))(wp-(.*)|xmlrpc)\.php$/m
str = 'wp-this.php
wp-settings.php
wp-and.php
wp-config.php
that.php
xmlrpc.php
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end