$re = '/(?!.*(?:this|and|that))(wp-(.*)|xmlrpc)\.php$/m';
$str = 'wp-this.php
wp-settings.php
wp-and.php
wp-config.php
that.php
xmlrpc.php
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);